This project has moved and is read-only. For the latest updates, please go here.

Word freezes when opening layout designer

May 28, 2013 at 10:08 AM
Hi,
I've downloaded the recent version of the add-in
I use the 32-bit version on windows 7, word 2010, TFS 2010
When trying to open the designer word hangs and wont respond until I close the process

Any idea regarding this behavior?
May 28, 2013 at 10:27 AM
I have never seen this before. Is it possible that there is an error dialog open somewhere that might be blocking Word?

One other thing you could try is to use the SysInternals DebugView tool. The addin outputs some trace information and it may provide some useful information in there.

Thanks

Rob
May 28, 2013 at 8:25 PM
Hi,
I didnt notice any hidden dialog

This is the log received from the debugview utility:
[8468] WORD4TFS 22:21:48.151 Add in doc change, process id 8468
[8468] WORD4TFS 22:21:48.152 Application document change event.
[8468] WORD4TFS 22:21:48.153 Constructing WordDocument for Document2, underlying document hash is 9521066
[8468] WORD4TFS 22:21:48.153 Word document changed to: Document2
[8468] WORD4TFS 22:21:48.156 Handle for document Document2 is Document2
[8468] WORD4TFS 22:21:48.157 Creating a new Team Project Document
[8468] WORD4TFS 22:21:48.193 Document changed to: Document2
[8468] WORD4TFS 22:21:48.194 Getting layouts from template.
[8468] WORD4TFS 22:21:48.194 Getting layouts from template.
[8468] WORD4TFS 22:21:48.196 Getting layouts from template.
[8468] WORD4TFS 22:21:48.197 Getting layouts from template.
[8468] WORD4TFS 22:21:48.210 Getting layouts from template.
[8468] WORD4TFS 22:21:48.219 Getting layouts from template.
[8468] WORD4TFS 22:21:48.220 Exporting layout Card (Agile)
[8468] WORD4TFS 22:21:48.221 Exporting layout building block Default hash 49143529 ID {40F28A9E-C530-4053-B1D0-21E5AD22F231}
[8468] WORD4TFS 22:21:48.277 Inserting building block for bookmark _Temp_0 at current position
[8468] WORD4TFS 22:21:48.345 Bookmark for new content at destination is _Temp_0


Is there another way to perform editing of templates?
May 30, 2013 at 9:36 AM
It seems to have hung after exporting the first of the building blocks that make up the Card(Agile) layout.

Can you successfully import using the Card(Agile) layout? Please try it with any query that returns Tasks, Bug or User Story work items.

It is possible to change layouts manually. A layout is just a set of Building Blocks that follow a particular naming convention. If you look in the Building Blocks Organizer (under Quick Parts on the Insert ribbon) you will see how they are organised. To get fields into the Building Block you have to add Plain Text or Rich Text content controls (you have to enable the Developer ribbon for this) and set the Tag to be the Reference name of the field in TFS.

Regards

Rob
Jun 13, 2013 at 4:42 PM
Hi,
I tried to get back to reviewing this issue from my side but now the add-on doesn't load

When I execute the Microsoft.Word4Tfs.WordAddIn.vsto file from C:\Program Files\Team Foundation Server Word Add-in I get this message:

Name: Microsoft.Word4Tfs.WordAddIn
From: file:///C:/Program Files/Team Foundation Server Word Add-in/Microsoft.Word4Tfs.WordAddIn.vsto

************** Exception Text **************
System.Deployment.Application.InvalidDeploymentException: Reference in the manifest does not match the identity of the downloaded assembly Microsoft.Word4Tfs.Library.dll.
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.DownloadAddIn(TimeSpan timeout)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

Is it possible that there is some issue with the manifest file?

Any ideas?

Thanks
Assaf
Jun 16, 2013 at 11:58 PM
Sorry for the delay replying. Something has to have changed if it loaded before and does not load now. Can you try uninstalling and making sure it has completely gone before installing it again? Can you also confirm that you are installing the 32 bit version of the addin and that Word is also the 32-bit version?

Regards

Rob
Jul 1, 2013 at 4:15 PM
Hi,
Short update
I didn't succeed in resolving the issue on my machine, but I tried installing the add-in on a clean machine and it worked, so its indeed an issue with my machine

On the new machine the layout editor will not start as well and word freezes but I managed to play with the building blocks and was able to change and understand how it works

Thanks
Assaf
Jul 1, 2013 at 4:22 PM
Well, I am glad you got it to work, but I am really puzzled as to why the layout designer freezes Word for you. I am not too sure what to suggest. Can you get a managed call stack perhaps to see where in the code it is stuck?

Regards

Rob
Jul 2, 2013 at 11:23 AM
Sure,
Could you assist with some directions for achieving that stack?
Jul 2, 2013 at 11:29 AM
You could try attaching to the Word process from Visual Studio. Unfortunately the PDBs are not included in the installer so I am not sure how much info you will manage to get, but it is worth a try.

Regards

Rob