This project has moved. For the latest updates, please go here.

TFS 2013 and Visual Studio 2013 Support

Feb 7, 2014 at 9:02 PM
Any plans for TFS Server 2013 and Visual Studio 2013? Your latest version supports TFS Server 2012. Running VS 2013, when I attempt to install it, it tells me it requires the TFS Server 2012 object model (installed by team explorer 2012).
Developer
Feb 11, 2014 at 10:25 PM
I have started the work to support the 2013 Object Model. In the meantime the 2012 Object Model will work against TFS 2013.

Regards

Rob
Feb 11, 2014 at 10:47 PM
I have Team Explorer for VS 2013 installed. Can I install Team Explorer 2012 also, in order to get the 2012 Object Model?
Developer
Feb 12, 2014 at 7:09 AM
It should certainly be possible, I have both on my machine, although 2012 was installed before 2013.

Regards

Rob
Feb 13, 2014 at 8:01 PM
I was able to install Team Explorer 2012 along side Team Explorer 2013 with no problem. I rebooted and I still get the same message when I try to install your software. Any ideas?
Developer
Feb 13, 2014 at 8:24 PM
Can you install the MSI manually using the following command:

msiexec /I <msifile> /l*xcv log.txt

and post the log.txt file somewhere so I can view it?

Thanks

Rob
Feb 14, 2014 at 12:50 AM
Not sure where to post it.
Developer
Feb 14, 2014 at 7:03 AM
Could you post it on SkyDrive?

Thanks

Rob
Feb 14, 2014 at 3:14 PM
Developer
Feb 14, 2014 at 4:48 PM
From what I can see in the installer log it looks like it cannot detect the presence of the TFS 2012 object model. It checks the following registry key:

HKLM\SOFTWARE\Microsoft\TeamFoundationServer\11.0\InstalledComponents\ObjectModel

For a value called Installed, this should have the value 1.

Can you check if this value is in the registry? Make sure you check in the 32-bit registry.

Regards

Rob
Feb 14, 2014 at 10:28 PM
I don't have the 11.0 node. I have 12.0. 12.0 must be VS 2013 and Team Explorer 2013. I installed Team Explorer 2012 the other day and it did say successful. Should I install VS 2012 to see if that fixes it?
Developer
Feb 17, 2014 at 4:47 AM
I can't explain why installing Team Explorer 2012 did not work. You could try installing the 2012 object model from here: http://visualstudiogallery.msdn.microsoft.com/f30e5cc7-036e-449c-a541-d522299445aa.

Regards

Rob
Feb 17, 2014 at 9:50 PM
It all works now. Thanks for the help. After installing the object model, the installation of your software was successful. The tool works fine.